the tool cant read or the xml file

BravoMan's Avatar

BravoMan

11 Dec, 2009 10:16 AM

im useing the laetest realese

  1. 1 Posted by Alex "Alex... on 11 Dec, 2009 10:26 AM

    Alex "Alexspeed" Bachner's Avatar

    Please locate your addins.xml under "C:\Documents and Settings\YOURNAME\My Documents\BioWare\Dragon Age\Settings" and attach it to the post you make like you did with the screenshot, thank you =)

    Continuation of conversation started here: http://thenexusforums.com/index.php?showtopic=168045

  2. 2 Posted by BravoMan on 11 Dec, 2009 10:33 AM

    BravoMan 's Avatar

    ok,heres my file

  3. 3 Posted by Alex "Alex... on 11 Dec, 2009 03:08 PM

    Alex "Alexspeed" Bachner's Avatar

    sorry forget that comment, file is showing up now correct, had to refresh my browser ;)

  4. Support Staff 4 Posted by jwvanderbeck on 11 Dec, 2009 03:29 PM

    jwvanderbeck's Avatar

    Your XML file contains invalid encoding, and thus is not readable. Version B2.1.2 has a Sanitize tool that can fix it, but if your native language is not English, I would wait until later today. I'm writing a better tool for fixing it.

  5. 5 Posted by BravoMan on 11 Dec, 2009 03:59 PM

    BravoMan 's Avatar

    well thank you for that i guess ill have to re-install the game,will you be posting it on the nexus?ill keep an eye on that

  6. Support Staff 6 Posted by jwvanderbeck on 11 Dec, 2009 04:02 PM

    jwvanderbeck's Avatar

    You don't have to reinstall the game. If your native language is English you can go ahead and use the Sanitize XML tool in the latest version. That will fix the file, but it will also destroy most all characters that are not standard English. If your native language is not English, then just hold tight and I should have a better fix later today.

  7. Support Staff 7 Posted by jwvanderbeck on 11 Dec, 2009 04:28 PM

    jwvanderbeck's Avatar

    Well I thought I could fix this but I can't :(

    The only option is to either Sanitize the XML which is perfectly fine for English, but really horrible for some languages like Russian. It is worth a try first though to see how it looks for your language. If Sanitize doesn't work for you, then re-installing might be a better choice.

    The problem is that some of these files have had their encoding destroyed, presumably by being edited by hand in a program that didn't properly write the encoding back out. They are supposed to be UTF-8 encoded, but what this error occurs its because they aren't anymore. I was hoping I could re-construct the encoding but as I got deeper into it I saw that many of the details were already lost, and there isn't any way I can recreate them.

    So in short, try a Sanitize XML and see how it looks in your language. If you don't like the result, the only other option I have at the moment is to re-install the game. Unless its possible to uninstall the Bioware DLC and then re-install them, but I don't think they let you do that.

  8. jwvanderbeck closed this discussion on 11 Dec, 2009 05:38 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac