Beta 1.6 Available

jwvanderbeck's Avatar

jwvanderbeck

03 Dec, 2009 04:03 PM

DAModder version B1.6 is now available

New version is attached

  • Fixed bug that prevented DAModder from properly installing an add in when there were no previous add ins installed. This resolves issue #33

  • Fixed bug that could cause an invalid XML state if the mod's manifest had entries containing no CDATA like expected. This resolves issues #32 & #30

  • Fixed a bug that could cause a crash when clicking in the Installed Mods list, but not actually clicking on a Mod.

  • Initial support for packaging core override mods. This will be cleaned up and improved in a future version.

  • Initial support for installing core override mods. There is no uninstall at this point, so uninstalling has to be done by hand.

  • Fixed a bug in ParseModDetailsFromManifest that would cause the mod's Version field to not be parsed properly.

  • UI is now properly reset after uninstalling a mod. Resolves issue #27

Please discuss it here, and submit bug reports to the bug tracker

  1. 1 Posted by adaram on 03 Dec, 2009 04:12 PM

    adaram's Avatar

    Wow -- I didn't even have a chance to test 1_5

    Good stuff

    I am a little busy at work today, but I'll try and find some time to look at this build later. Not sure I want to mess with my game right now, though, since the new database broke my Shale conversations :( Hopefully I can get it fixed so I don't lose the last 3 days of progress :(

    Thanks JW for the great work!

  2. 2 Posted by Alex "Alex... on 03 Dec, 2009 05:23 PM

    Alex "Alexspeed" Bachner's Avatar

    Thank you John, i also didnt get to test B1.5, but i downloaded 1.6 now and will do some installing/uninstalling tests with it.

    What about the support for core override mods, can they be now installed allready or is just the code in it for a future version?
    If its possible to install them now i would test that functionality too, do they have to be set up like the .dazip mods in a folder?

  3. Support Staff 3 Posted by jwvanderbeck on 03 Dec, 2009 05:26 PM

    jwvanderbeck's Avatar

    B1.6 can install core override mods, it just can' t uninstall them. It does however package the nicely so you can simply go into your packages\core\override directory and delete them. It puts the files into a subfolder named after the mod's UID.

    You do have to package them but its a bit easier since there is some support from the application. I'll post a FAQ for it. I already wrote the instructions in my code, so it will only take me a few moments.

  4. Support Staff 4 Posted by jwvanderbeck on 03 Dec, 2009 05:37 PM

    jwvanderbeck's Avatar

    Here is the FAQ detailing how to make a package for core override mods

    B1.7 can uninstall these mods. I already have it working.

  5. 5 Posted by Alex "Alex... on 03 Dec, 2009 05:46 PM

    Alex "Alexspeed" Bachner's Avatar

    okay great John thank you for the quick answer and the faq, i will deffinatly give it a go, any timeshedule on when B1.7 will be aviable?

  6. Support Staff 6 Posted by jwvanderbeck on 03 Dec, 2009 06:05 PM

    jwvanderbeck's Avatar

    Later today for sure. Not certain when. Depends on how much of the backup stuff I decide to do.

  7. jwvanderbeck closed this discussion on 03 Dec, 2009 11:30 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac