Having trouble installing mods

zechariah.metzler's Avatar


15 Dec, 2015 12:31 AM

Hi Guys!

I'm sure you get this question all time but I'm having a hard time find my solution.

First time user of DAModder long time supporter of mods and games that support them.

I'm using DAmodder and I'm trying to install mods for DAO. I have the ultimate edition if that matters. I've downloaded my mods from Nexusmods.com. For somer reason they keep downloading in .RAR format,even though I use Winzip and WinRaR isn't even installed on my computer. Since DAModder won't recognize those fie types, I followed the alternate installation instructions (manually extract to a temporary folder and drag and drop into DAModder), I even tried manually installing it through the "install" button within the program. I get the same error every time "this is not a DAZIP or .Zip file." When I manually extract and install I get an "unhanded exception has occurred in your application".

I've even tried mods that go into the override folder you create in the packges/core/ and they won't open correct or extract at all to that spot.

What am I doing wrong?

Thank you for your help!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac